Windows Boot Manager UEFI
create a boot using bootx64.efi - can't see windows boot manager in uefi
Why Windows Boot Manager is not in UEFI list? no bootable devices found solved
missing the Windows Boot Manager entry - Windows cannot boot in legacy or UEFI
Can't boot on windows 10, Windows Boot manager entry has disappeared from UEFI
GPT partition scheme for UEFI" and formatting in FAT32
Windows won't boot in UEFI mode, deleted EFI partition.


cd Boot Security Legacy
legacy UEFI
windows boot manager UEFI

no bootable devices found
cd boot f12
windows boot manager .


1- UEFI fat32
2- RUFUS Rufus strictly for UEFI systems only
3- RUFUS winsetupfromusb
5- windows repair 10

  1. boot laptop
  2. press F12 when dell logo appears
  3. select BIOS setup
  4. navigate to Settings -> General -> Boot Sequence
  5. select UEFI, then click 'Add Boot Option'
    1. Boot Option Name: My Boot
    2. File System List: DONOT change
    3. File Name: \EFI\Boot\bootx64.efi
    4. click OK

  6. under Boot Sequence ticket "My Boot"
  7. save & apply changes
  8. reboot
  9. pray
  10. windoze 10 should finish updating

  • Deleted your Windows boot entry -- To boot in EFI mode, EFIs maintain a list of boot entries in NVRAM. It's possible that, when you switched to BIOS/CSM/legacy mode, your firmware deleted the EFI-mode entry for Windows. If so, then with that entry gone, your computer can no longer boot Windows in EFI mode. The solution to this problem is to re-create this boot entry.
  • Changed your boot order -- A single computer can have multiple NVRAM boot entries, so a boot order is also stored in NVRAM. Importantly, these entries can include both BIOS-mode and EFI-mode boot entries. It's possible that your firmware re-ordered these entries, putting a BIOS-mode entry at the top; and despite the fact that you've disabled BIOS-mode support, the computer is still trying to boot using that entry and failing.

Both these problems can be fixed in Windows, and the second may be fixable in your firmware setup utility, but details vary. As that's a relatively easy fix, though, I recommend you poke around in the setup utility for a way to adjust the boot order. The Windows entry is called "Windows Boot Manager." Be sure it's first in the boot order list. You should also review other settings; enabling your CSM may have automatically toggled something else that you need to switch back. Unfortunately, such details tend to be highly machine-specific, so you may need to ask on a forum dedicated to your brand of computer or motherboard.
If that fails, then there's probably a way to fix this with a Windows emergency disk; however, I'm not very familiar with such tools, so I can't tell you how to do it. I can, however, suggest a workaround that should get you booting temporarily and use Windows' regular tools to fix the problem:

  1. Disable Secure Boot on your computer. Details vary from one system to another; but see this page of mine for some examples of how to do it. (You can re-enable Secure Boot when you're done.) Note that not all computers support Secure Boot, but almost everything that shipped with Windows 8 and later does.
  2. Download the USB flash drive or CD-R version of my rEFInd boot manager. Download links for both types of media are on that page.
  3. Prepare a bootable medium from the rEFInd image you download.
  4. Boot using the rEFInd medium. It should detect your Windows installation and enable you to boot it.
  5. In Windows, open an Administrator Command Prompt window and type bcdedit /set {bootmgr} path \EFI\Microsoft\Boot\bootmgfw.efi. This should create a new Windows boot entry and make it the default.
Reset UEFI Firmware to Defaults