Cloud Linux This system is receiving updates from CloudLinux
Failed to check whether running executables are up-to-date: The system received unexpected output from /usr/bin/needs-restarting: This system is receiving updates from CloudLinux Network server.
Security Advisor failed to run with unexpected output



:

an issue appear Inside cPanel Security Advisor :


Failed to check whether running executables are up-to-date: The system received unexpected output from /usr/bin/needs-restarting: This system is receiving updates from CloudLinux Network server.

and after cPanel & WHM update failure in upcp script:


[2022-08-20 21:53:39 +0200] E [/usr/local/cpanel/scripts/find_outdated_services] STDOUT: This system is receiving updates from CloudLinux Network server.

I tried "needs-restarting" script then "yum clean all" then reboot the server but still the issue since month till now.

:



:
usr/bin/needs-restarting



:
 yum clean all



https://cloudlinux.zendesk.com/hc/en-us

Doctor Key



:
wget -qq -O - https://repo.cloudlinux.com/cloudlinux/cldoctor/cldoctor.sh | bash

* :
cPanel
whm support.

-------------------------------------------------------------------



cPanel Ticket

.


This is a known issue with CloudLinux 8 and Security Advisor. The output below is unfamiliar to Security Advisor, so it throws a warning, but this can safely be ignored:
[04:59:27 server root@94476988 ~]cPs# /usr/bin/needs-restarting
This system is receiving updates from CloudLinux Network server.

We have published and outlined more information in the following support article:

Security Advisor failed to run with unexpected output

Our developers are aware of this issue and are working on a fix. It is currently only a UI issue, as running the needs-restarting binary from SSH works properly. For the time being, the UI report can be safely ignored. We apologize for any inconvenience. If you have any further questions or concerns, cPanel Support is always here to help.