Cloud Linux /usr/local/cpanel/scripts/update-packages
cannot install the best update candidate for package ea-apache24-mod_lsapi
cPanel & WHM update failure in upcp script
Problem: cannot install the best update candidate for package ea-apache24-mod_lsapi
When installing ea-apache24-mod_lsapi the "Cannot install the best candidate for the job" error occurs
Can't install LSAPI due to Error: ea-liblsapi conflicts with 1:liblsapi-1.1-39.el7.cloudlinux.x86_64
/usr/bin/yum reported error code 1 when it ended



:

cPanel & WHM update failure in upcp script


[/usr/local/cpanel/scripts/update-packages] The /usr/local/cpanel/scripts/update-packages command (process 3714450) reported error number 1 when it ended.



:
/usr/local/cpanel/scripts/update-packages




Error:
Problem: cannot install the best update candidate for package ea-apache24-mod_lsapi-1:1.1-64.el8.cloudlinux.x86_64
- nothing provides liblsapi >= 1:1.1-65 needed by ea-apache24-mod_lsapi-1:1.1-65.el8.cloudlinux.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

:

testing repository
1. Check if the updates-testing repository is enabled on your server:



:
yum repolist
2. Example of the updates-testing repository in the output:
testing cl-ea4-testing



3. Disabled this repository and install the lsapi:



:
yum-config-manager --disable cl-ea4-testing

:
install liblsapi liblsapi-devel
install ea-apache24-mod_lsapi




:
/usr/local/cpanel/scripts/update-packages
Complete



Upgrade to Latest Version whm
complete



:
https://forums.cpanel.net/threads/cp...script.702253/
https://cloudlinux.zendesk.com/hc/en...b-error-occurs
https://support.cpanel.net/hc/en-us/...udlinux-x86-64
https://forums.cpanel.net/threads/pr...dlinux.692261/