Error: Validation for transport failed: Could not upload test file
Error: Validation for transport failed: Could not upload test file: upload_file_content_single() missing upload_uri at /usr/local/cpanel/3rdparty/perl/536/cpanel-lib/Net/Google/Drive/Simple/V3.pm line 996
Google Drive backup validation failure: "Could not create path directory"
Validation for transport failed: Could not upload test file: Accepted data connection



:


⛔ Backup transport errors
Backup Configuration / Additional Destinations
Validate Test

Error: Validation for transport failed: Could not upload test file: upload_file_content_single() missing upload_uri at /usr/local/cpanel/3rdparty/perl/536/cpanel-lib/Net/Google/Drive/Simple/V3.pm line 996


Google Drive

:


Limit Limit

Description We've seen this caused by the "Queries per 100 seconds per user" setting in the quota management area of the Google Drive API settings being set too low. It seems that this can be set to a value of "1" when the default is "100" and the maximum value for this setting is "1000."


:



Limit
Google API

Per our documentation, How to Configure Google Drive as a Backup Additional Destination, it's recommended to increase your Google API quota.
Please note, Google imposes limits and quotas on their APIs. This can cause errors when you back up your server to Google Drive.
To avoid errors due to these limitations, we recommend that you perform the following steps to increase your default quota settings:


  1. Visit the Google API Manager website.
  2. In the left side navigation bar, click "Google Drive API".
  3. Click "Quotas".
  4. Increase the value of the "Queries per 100 seconds per user" setting.
    Please note, maximum value of 1000 usually resolves these errors. However, a lower setting may sufficiently resolve most errors.
  5. Click "Done".




:
Google drive API enable

:
https://support.cpanel.net/hc/en-us/...ath-directory-
https://support.cpanel.net/hc/en-us/...19655644328087
https://docs.cpanel.net/knowledge-ba...257.1696885008