حل مشكلة Empty Sitemap - Your Sitemap does not contain any URLs
Your Sitemap does not contain any URLs. Please validate and resubmit your Sitemap
مشكلة تفعيل Cloud Flare وتراجع فى ترتيب الموقع و الارشفة و ترتيب Alexa


سبب المشكلة :

المشكلة فى اضافة All In One WP Security داخل الووردبريس يعمل Conflict

وتظهر المشكلة بعد تفعيل Cloud Flare وتراجع فى ترتيب الموقع و الارشفة و ترتيب Alexa

يمكنك مراقبة ذلك داخل Google Search Console

حل المشكلة :



ولان كلاودفلير يعمل بنظام البروكسي لذلك يحدث تعارض مع Block Fake Googlebot

وبالتالى يجب الغاء تفعيلها حتى لا يحظهر عناكب جوجل وغيرها من العناكب

From the WordPress menu on the left navigate to WP Security >>
Firewall and look for the "Internet Bots" tab.
Deactivate the "Block Fake Googlebots" option and click save.

This solution solved my problem for sitemaps generated by both
the "Yoast SEO" plugin for WordPress and the "Google XML Sitemaps" plugin for WordPress.


حل اخر

Yoast SEO generates sitemap_index.xml, not sitemap.xml.
Please, submit the sitemap_index.xml and which should resolve the issue.

المرجع:
https://stackoverflow.com/questions/...it-your-sitema
https://wordpress.org/support/topic/...-to-read-them/