+
1 4 4
  1. #1
    Status
    Offline
      Rise Company
    Engineering and Technology
    Apr 2014
    Egypt
    4,030
    10

    SMTP error from remote mail server after end of data: 550 Action not taken


    SMTP error from remote mail server after end of data: 550 Action not taken
    SMTP error from remote mail server after end of data: 550 Action not taken
    Email Forwarder Mail delivery failed: returning message to sender
    X-From-Rewrite: unmodified, actual sender is mailnull



    :

    PTR
    leafdns.com




    gmail / hotmail / yahoo
    mail delivery failed

    :

    2 IP PTR
    ptr ns1 ns2

    https://www.whatsmydns.net/#PTR/

    whm
    IP
    PTR





    *


    :
    https://bloggymcblogface.blog/smtp-e...ion-not-taken/
    http://www.leafdns.com/
    https://www.whatsmydns.net/#PTR/
    https://forums.cpanel.net/threads/al...g-time.640785/

    ------------------------------------------------------------------------
    Rise Company for Engineering & Technology
    ------------------------------------------------------------------------
    Web Hosting | Web Designing | E-Marketing

    # 1 Business Services

    Web Hosting - Business Emails

    Web Design - Google Adwords

    www.rise.company | www.rise.company/emails

    :
    ! .



  2. #2
    Status
    Offline
      Rise Company
    Engineering and Technology
    Apr 2014
    Egypt
    4,030
    10

    : SMTP error from remote mail server after end of data: 550 Action not tak




    ------------------------------

    Email Forwarder gmail
    Mail delivery failed: returning message to sender
    SMTP error from remote mail server after end of data: 550 Action not taken

    Email Routing Local Mail Exchanger Remote



    Email Deliverability





    :

    test

    attachments pdf
    rename



    Have you set up a new mail server, configured DKIM and SPF correctly, but for some reason you still have email being intermittently rejected when forwarding to Gmail and other services with messages that are unhelpful like:
    SMTP error from remote mail server after end of data: 550 Action not taken
    If thats the case, you may need to set up a DNS PTR record for your mail servers IP address. It appears that, depending on the circumstances of the forwarded email and the domain performing the forwarding, this step is crucial to ensure smooth email forwarding delivery.
    Of course, you should ensure that the PTR record IP address and hostname match what you see in the SMTP header.



    Update 31st Oct 2018:
    Since writing this article a few days ago, I encountered some further issues with reliable mail delivery, specifically through Exim on cPanel.
    Normally, when configuring forwarding, you should also enable SRS (Sending Rewriting Scheme), which adds additional information to the mail headers to inform the receiving MTA that the email has been forwarded and signed by the forwarding MTA (in my case, Exim on a cPanel/centOS installation).
    While this was enabled in the Exim config, I did not realise that it wasnt actually operating correctly.
    Below is what you SHOULD see when SRS is operating correctly (forwarding to a Gmail account):
    Received-SPF: pass (google.com: domain of srs0=lu0ygv=nl=senderoriginaldomain.com=senderfirs [email protected] designates <your MTA IP> as permitted sender) client-ip=<your MTA IP>;
    Authentication-Results: mx.google.com;
    dkim=pass [email protected] header.s=default header.b=HnochmZG;
    dkim=pass [email protected] header.s=default header.b=C8B9JAt8;
    spf=pass (google.com: domain of srs0=lu0ygv=nl=senderoriginaldomain.com=senderfirs [email protected] designates <your MTA IP> as permitted sender) smtp.mailfrom=SRS0=Lu0yGv=NL=senderoriginaldomain [email protected];
    Heres what it looks like WITHOUT SRS (again, forwarding to a Gmail account):
    Received-SPF: fail (google.com: domain of [email protected] does not designate <your MTA IP> as permitted sender) client-ip=<your MTA IP>;
    Authentication-Results: mx.google.com;
    spf=fail (google.com: domain of [email protected] does not designate <your MTA IP> as permitted sender) [email protected] omain.com;
    dmarc=fail (p=NONE sp=NONE dis=NONE) header.from=senderoriginaldomain.com
    As you can see, in the SRS example, the sender information is modified to include information about the forwarding domain (i.e. your domain) so that it is clear that your MTA is not trying to forge or spoof the original senders domain.
    In my case, SRS was turned on properly, however it seems that the cPanel archiving functionality was somehow breaking this on the version of cPanel that I was running. As a workaround, I will be disabling email archiving to ensure that SRS is applied to my forwarded messages and applying any cPanel updates as they are released that will hopefully resolve the issue.

    Final Update 3rd November 2018:
    Further to my last update, it seems that I had another factor contributing to this issue Namecheap (my previous provider) had been intercepting my SMTP traffic through the use of a transparent SMTP proxy of some description (they were not forthcoming with information).
    It seems that this was also causing mail delivery issues that were causing the likes of Gmail and Microsoft to return 550 back to my server after transmitting messages.
    After unsuccessfully attempting to persuade Namecheap to allow me to bypass this technology, I have moved to a new VPS provider and my emails are again being delivered perfectly.

    -----------------------------------


    updating Send mail from the accounts IP address from On to Off

    -----
    csf

    PACKET_FILTER =
    Off
    Perform reverse DNS lookups on IP addresses. See also CC_LOOKUPS

    -----
    LF_QUEUE_ALERT = 0
    Email Routing Configuration
    -----

    whm

    • Home /
    • DNS Functions /
    • Email Routing Configuration

    The lowest numbered MX entry currently points to: ns2.rose-eg.com
    Email Routing for ns2.rrrrr.com (The domain is owned by nobody).


    Local Mail Exchanger

    ns1.rrrrr.com
    ns2.rrrrr.comserver.rrrrr.com
    rrrrr.com





    ------------------------------------------------------------------------
    Rise Company for Engineering & Technology
    ------------------------------------------------------------------------
    Web Hosting | Web Designing | E-Marketing

    # 1 Business Services

    Web Hosting - Business Emails

    Web Design - Google Adwords

    www.rise.company | www.rise.company/emails

    :
    ! .



  3. #3
    Status
    Offline
      Rise Company
    Engineering and Technology
    Apr 2014
    Egypt
    4,030
    10

    : SMTP error from remote mail server after end of data: 550 Action not tak

    Exim by default listens on 587, allowing mail clients to connect over this port. The issue you're experiencing occurs when your provider closes port 25 but exim is not listening on an alternate port. You can change this by going to WHM>>Service Configuration>>Service Manager and select Exim Mail Server (on another port) and allow port 26.
    ------------------------------------------------------------------------
    Rise Company for Engineering & Technology
    ------------------------------------------------------------------------
    Web Hosting | Web Designing | E-Marketing

    # 1 Business Services

    Web Hosting - Business Emails

    Web Design - Google Adwords

    www.rise.company | www.rise.company/emails

    :
    ! .



  4. #4
    Status
    Offline
      Rise Company
    Engineering and Technology
    Apr 2014
    Egypt
    4,030
    10

    : SMTP error from remote mail server after end of data: 550 Action not tak

    Same exact problems here (and I dont see a more recent thread).

    It looks to me like this is a cached response as I dont even see a delivery attempt, just instafail at 'lookuphost' without a reason. I do not think this is a resolver problem, I can look stuff up no problem, and ping it (careful, host(1) ignores /etc/hosts, so could be something hidden in there, not in my case), but I do not get a proper error response

    Code:
    2019-05-23 12:43:50 cwd=/tmp 4 args: send-mail -i -- [email protected]
    2019-05-23 12:43:50 1hTqoo-0007EE-LC <= [email protected] U=root P=local S=517 T="test" for [email protected]
    2019-05-23 12:43:50 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1hTqoo-0007EE-LC
    2019-05-23 12:43:50 1hTqoo-0007EE-LC ** [email protected] R=lookuphost T=remote_smtp: all hosts for 'mydomain.com' have been failing for a long time (and retry time not reached)
    2019-05-23 12:43:51 cwd=/var/spool/exim 7 args: /usr/sbin/exim -t -oem -oi -f <> -E1hTqoo-0007EE-LC
    2019-05-23 12:43:51 1hTqop-0007EN-0G <= <> R=1hTqoo-0007EE-LC U=mailnull P=local S=1866 T="Mail delivery failed: returning message to sender" for [email protected]

    I can telnet to the mx record for the mydomain.com above port 25 no problem.

    How do I force it to try again to see what the actual failing reason is? Setting log_selector to +all doesnt help with any additional detail.

    [EDIT] *SOLVED*

    Never saw this mentioned in the few threads about this problem here.

    Code:
    :
    
    
    :
    cd /var/spool/exim/db
    rm wait-dkim_remote_smtp* retry* wait-remote_smtp*
    service exim restart
    And then new and queued mail got sent out (because whatever other underlying problem I had solved earlier with another change, but somehow exim didnt get told about it despite having restarted it a few times to increase logging or other reasons).

    https://forums.cpanel.net/threads/dkim_lookuphost-issue.606047/


    ------------------------------------------------------------------------
    Rise Company for Engineering & Technology
    ------------------------------------------------------------------------
    Web Hosting | Web Designing | E-Marketing

    # 1 Business Services

    Web Hosting - Business Emails

    Web Design - Google Adwords

    www.rise.company | www.rise.company/emails

    :
    ! .